Enhancement #1123

Improve documentation for debian package installation wrt spread transport

Added by C. Emmerich about 9 years ago. Updated about 9 years ago.

Status:NewStart date:08/03/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

After installing rsb0.7 and rsbcpptools0.7 with debian packages, rsb throws a runtime error:

terminate called after throwing an instance of 'rsc::patterns::NoSuchImpl'
  what():  no implementation of interface `rsb::transport::InPushConnector' found for specified key `spread'
Aborted

Note: I do not remember this issue occuring when I installed rsb0.7 manually...


Related issues

Related to Robotics Service Bus - Bug #1124: Debian package rsb-tools-cpp0.7 depends strictly on rsb0.... Closed 08/03/2012

History

#1 Updated by J. Wienke about 9 years ago

You need to install rsb-spread, otherwise you end up with an rsb version without spread support.

#2 Updated by Anonymous about 9 years ago

Seems to be correct, that the rsb package doesn't include the spread transport.
However:
  1. rsb-spread package is missing on the server right now,. this is probably just a temporary issue due to package server resetting
  2. rsb0.7 troubleshooting docs should point to the rsb-spread package as solution for Problem 1 (spread doesn't work anymore)
  3. The raised exception could be clearer, for example saying that rsb is built without spread

#3 Updated by J. Wienke about 9 years ago

  • Tracker changed from Bug to Enhancement
  • Subject changed from RSB0.7 debian package seems to be misconfigured to Improve documentation for debian package installation wrt spread transport
  • Priority changed from Urgent to Normal

For the package server there actually is a file in the pool. So the index must be broken.

Please open up a second issue for the package server thing.

Also available in: Atom PDF