Bug #1522

FindBoostUUID reset Boost_LIBRARIES varialbe when used with last CMake version

Added by S. Herbrechtsmeier over 9 years ago. Updated over 9 years ago.

Status:ResolvedStart date:05/29/2013
Priority:NormalDue date:
Assignee:J. Wienke% Done:

100%

Category:cmake
Target version:Robotics Service Bus - rsb-0.9

Description

The FindBoostUUID.cmake reset the Boost_LIBRARIES variable because it calls FindBoost without any component. The last version of FindBoost.cmake from CMake reset the Boost_LIBRARIES variable on every call.

Associated revisions

Revision ebfafed3
Added by J. Wienke over 9 years ago

fixes #1522: Prevent resetting boost components

Only search for boost if this has not been done before to avoid
resetting the required boost components.

History

#1 Updated by J. Wienke over 9 years ago

I have no idea how to solve this correctly. FindBoostUUID can never know what a previous caller might have indicated as a component array.

Generally I would say we can start to drop this macro, because boost uuid is included in boost since some time now, but we still have some special systems using lucid, and in lucid uuid was not included.

#2 Updated by J. Wienke over 9 years ago

We coud even consider reporting this upstream. I don't know if this is really the intended behavior for the FindBoost macro.

#3 Updated by S. Herbrechtsmeier over 9 years ago

They change the behaviour with this commit: http://cmake.org/gitweb?p=cmake.git;a=commit;h=0100f88e298c6766d60108537010ede0f83da1dd

Can't you test Boost_FOUND and if it isn't set you can call FindBoost?

#4 Updated by J. Wienke over 9 years ago

  • Status changed from New to In Progress
  • Target version set to rsb-0.9

#5 Updated by J. Wienke over 9 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Applied in changeset rsc|commit:ebfafed3cc969b90b43bc35688af1b2d08e1cb5c.

Also available in: Atom PDF