Bug #2079

Format string in warning about duplicate converters is wrong

Added by J. Moringen over 6 years ago. Updated over 6 years ago.

Status:RejectedStart date:11/08/2014
Priority:LowDue date:
Assignee:J. Wienke% Done:

100%

Category:Java
Target version:rsb-0.12

Description

From a bug report:

Ich weiß nicht wie problematisch das ist, aber im flobi server output von InproTK fliegen ziemlich viele Warnings:

> 125403 [Thread-4] INFO inpro.synthesis.RobotSynthesisInformer  - set speak...
> --> Robot: /mobile/flobi using middleware: RSB has been initialized
> --> Robot: Talking to /mobile/flobi
> 14:12:32.128 WARNING DefaultConverter  Converter with signature {0} already registered in DefaultConverterRepository. Existing entry will be overwritten!
> 14:12:32.129 WARNING DefaultConverter  Converter with signature {0} already registered in DefaultConverterRepository. Existing entry will be overwritten!
> 14:12:32.129 WARNING DefaultConverter  Converter with signature {0} already registered in DefaultConverterRepository. Existing entry will be overwritten!
> 14:12:32.129 WARNING DefaultConverter  Converter with signature {0} already registered in DefaultConverterRepository. Existing entry will be overwritten!
> 14:12:32.129 WARNING DefaultConverter  Converter with signature {0} already registered in DefaultConverterRepository. Existing entry will be overwritten!
> 

Das könnte daran liegen, dass bei jeder Synthese ein neues "Robot"-Objekt erstellt wird.

History

#1 Updated by J. Moringen over 6 years ago

  • Target version changed from rsb-0.11 to rsb-0.12

#2 Updated by J. Wienke over 6 years ago

  • Status changed from New to Rejected
  • Assignee set to J. Wienke
  • % Done changed from 0 to 100

I can't reproduce this here. The format string is correctly expanded. I suspect some kind of user settings to the logger prevents this, since the output is not the default one of the logging system.

Also available in: Atom PDF