Support #2224

rsb-loggercl cannot find exisiting protofile

Added by N. Köster over 6 years ago. Updated over 6 years ago.

Status:RejectedStart date:04/20/2015
Priority:LowDue date:
Assignee:J. Moringen% Done:

0%

Category:Common Lisp Tools
Target version:-

Description

I have a rather long rsb-locggercl call:

rsb-loggercl --max-queued-events=1 --on-error=continue \
             --idl-path="/vol/csra/releases/trusty/lsp-csra-nightly/share/rst0.11/proto/stable/"\
             --idl-path="/vol/csra/releases/trusty/lsp-csra-nightly/share/rst0.11/proto/sandbox/"\
             --idl-path="/homes/nkoester/workspace_csra/rct/rct-python/rct/proto"\
             --load-idl="/homes/nkoester/workspace_csra/rct/rct-python/rct/proto/FrameTransform.proto"\
             --style=detailed\
             spread:/

In which I provide 3 idl-paths and load my proto file FrameTransform.proto. However, it yields this error:

 <WARN> [10:47:46] [main thread] rsb.common error-handling.lisp (continue/verbose) - Error encountered; Recovering via restart

  | CONTINUE: Skip "/homes/nkoester/workspace_csra/rct/rct-python/rct/proto/FrameTransform.proto" 

  . Further processing may yield partial or incorrect results. Error was:

  | Failed to load data definition from source /homes/nkoester/workspace_csra/rct/rct-python/rct/proto/FrameTransform.proto. Caused by:
  | > Could not find a symbol for name "rst.geometry.Pose".

  .

Which I do not know why - the required symbol rst.geometry.Pose is within the given idl-path as expected:

[nkoester @ calcit] ls -la /vol/csra/releases/trusty/lsp-csra-nightly/share/rst0.11/proto/stable/@rst/geometry/Pose.proto
-rw-r--r-- 1 csracontrol csra 437 2015-04-17 11:17 /vol/csra/releases/trusty/lsp-csra-nightly/share/rst0.11/proto/stable/rst/geometry/Pose.proto

As far as I see it, there is no error in the FrameTransform.proto (I am actually sending and receiving it - so that works ...):

package rct;

import "rst/geometry/Pose.proto";
import "rst/timing/Timestamp.proto";

option java_outer_classname = "FrameTransform";
option java_package = "rct.proto";

/**
 * This is a container for rct internal use.
 *
 *
 * @author Leon Ziegler <lziegler@techfak.uni-bielefeld.de>
 */
message FrameTransform {

    optional        rst.geometry.Pose    transform     = 1;

    required        string               frame_parent  = 2;

    required        string               frame_child   = 3;

    optional        rst.timing.Timestamp time          = 4;
}

Am I doing something wrong here or is there a bug in the logger?


Related issues

Duplicates Robotics Service Bus - Bug #688: Name resolution does not work with absolute package names Feedback 10/31/2011

History

#1 Updated by N. Köster over 6 years ago

ups, i forgot to mention:

[nkoester @ calcit] rsb-loggercl --version
rsb-loggercl version 0.11.78-g3ecedae
SBCL version         1.2.6
RSB version          0.11.157-g0225164

#2 Updated by N. Köster over 6 years ago

turns out it is solvable when adding a dot in the proto description: rst.geometry.Pose -> .rst.geometry.Pose

package rct;

import "rst/geometry/Pose.proto";
import "rst/timing/Timestamp.proto";

option java_outer_classname = "FrameTransform";
option java_package = "rct.proto";

/**
 * This is a container for rct internal use.
 *
 *
 * @author Leon Ziegler <lziegler@techfak.uni-bielefeld.de>
 */
message FrameTransform {

    optional        .rst.geometry.Pose    transform     = 1;

    required        string               frame_parent  = 2;

    required        string               frame_child   = 3;

    optional        .rst.timing.Timestamp time          = 4;
}

#3 Updated by J. Moringen over 6 years ago

  • Duplicates Bug #688: Name resolution does not work with absolute package names added

#4 Updated by J. Moringen over 6 years ago

  • Status changed from New to Rejected

Duplicate.

Also available in: Atom PDF