Bug #1613

rsb-loggercpp0.10 (installed in toolkit-nightly) crashes on start

Added by C. Emmerich about 8 years ago. Updated about 8 years ago.

Status:RejectedStart date:09/05/2013
Priority:NormalDue date:
Assignee:J. Wienke% Done:

0%

Category:C++
Target version:rsb-0.10

Description

When starting the rsb-loggercpp0.10

/vol/toolkit/nightly/x86_64/bin/rsb-loggercpp0.10 --scope / --style monitor

the program instantaneously crashes with
Latency (us)   | Rate   |
   -nan ±   -nan|    0 Hz| /
terminate called after throwing an instance of 'rsc::patterns::NoSuchImpl'
  what():  no implementation of interface `rsb::transport::InPushConnector' found for specified key `spread'
Aborted

My rsb-conf looks like:

[transport.inprocess]
enabled = 1

[transport.socket]
enabled = 0

[transport.spread]
enabled = 1
host = augit
port = 4803

Is spread not longer supported or did I do anything wrong?

History

#1 Updated by J. Wienke about 8 years ago

  • Status changed from New to Rejected

Not a bug but an expected change in 0.10. The spread transport is now available as a plugin which needs to be loaded. Please have a look here:
http://docs.cor-lab.org/rsb-manual/0.9/html/troubleshooting.html#spread-does-not-work
You need to change your rsb.conf.

#2 Updated by J. Wienke about 8 years ago

Sorry, expected change since 0.9

#3 Updated by C. Emmerich about 8 years ago

thx. worked like a charme :D

#4 Updated by J. Wienke about 8 years ago

  • Category set to C++
  • Assignee changed from Anonymous to J. Wienke
  • Target version set to rsb-0.10

Also available in: Atom PDF