Support #1759

Pre-build Windows archive: incompatible rsbspread version

Added by R. Yaghoubzadeh over 7 years ago. Updated over 7 years ago.

Status:ResolvedStart date:02/11/2014
Priority:NormalDue date:
Assignee:J. Wienke% Done:

100%

Category:Packaging
Target version:rsb-0.11

Description

When checking out the current pre-built Windows ZIP (excellent feature! - for me, 32bit MSVC100), RSB works as long as rsbspread plugin is not specified in the conf: then it crashes because rsc0.10.dll is not present.

It seems the plugin is still on v0.10 and linked against 0.10 versions, but RSC and RSB are 0.11 already. Could the plugin be pulled to 0.11 as well? (... well, unless I misunderstand the problem...)

Incidentally, as a feature request: would it be possible to produce ZIPs for the most recent confirmed stable version in lieu / in addition of nightly CI builds?

Associated revisions

Revision 5911b8b9
Added by J. Wienke over 7 years ago

refs #1759: fix windows package ci job link

History

#1 Updated by R. Yaghoubzadeh over 7 years ago

The title was meant to read "Pre-built Windows archive: incompatible rsbspread version" :(

#2 Updated by J. Wienke over 7 years ago

  • Category set to Packaging

We had some troubles with the Windows salves recently. It might be that a build for trunk has not been triggered since the version change. So I suspect you are using trunk?

#3 Updated by J. Wienke over 7 years ago

  • Assignee set to J. Wienke

Oh and yes, we missed to port the package to 0.10. I will try to fix this.

#4 Updated by J. Wienke over 7 years ago

Jan, we need to add that job to the version bumping process.

#5 Updated by J. Moringen over 7 years ago

Jan, we need to add that job to the version bumping process.

  • Which job?
  • Where should something be added? The job copying program or the release script?
  • In case of the job copying program, there is no list of projects/jobs. It uses a regular expression to select jobs.

#6 Updated by J. Wienke over 7 years ago

Additionally, we need to fix version numbers in the CI build recipe on branching because windows doesn't use wildcards to abstract from these numbers.

#7 Updated by J. Wienke over 7 years ago

Jan Moringen wrote:

Jan, we need to add that job to the version bumping process.

  • Which job?

rsx-XXX-windows-package

  • Where should something be added? The job copying program or the release script?

Both

  • In case of the job copying program, there is not list of projects/jobs. It uses a regular expression to select jobs.

So we shouldn't forget that job then ;)

#8 Updated by J. Moringen over 7 years ago

Additionally, we need to fix version numbers in the CI build recipe on branching because windows doesn't use wildcards to abstract from these numbers.

Trying to do this automatically would quickly get us into diminishing returns territory and may also introduce subtle errors.

Where should something be added? The job copying program or the release script?

Both

What has to be changed in the release script?

So we shouldn't forget that job then ;)

I changed

:job-pattern "^rs(c|b|t|bag).*-trunk" 

to
:job-pattern "^rs(c|b|t|x|bag).*-trunk" 

#9 Updated by R. Yaghoubzadeh over 7 years ago

Oh, yes, I was using the trunk version, because that's the one that was linked from the 0.10 install page: http://docs.cor-lab.org/rsb-manual/0.10/html/install-binary.html#pre-compiled-windows-archive

Since the CI project list also shows an rsx-0.9 version (but not 0.10), I will try 0.9 tomorrow, for the time being. (I assume 0.9 will have no protocol trouble communicating with our Linux and OS X components that are on 0.10?)
Thanks for tackling this issue!

#10 Updated by J. Wienke over 7 years ago

Which version do you use on the other operating systems.

Independent of that I have just triggered a new build of the trunk package, which should hopefully fix the issues.

We also need to update that link in the documentation then.

#11 Updated by J. Wienke over 7 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

I have added a job for 0.10 and the trunk job should be fixed. What remains immediately is fixing the documentation to point to the correct versions.

#12 Updated by J. Wienke over 7 years ago

  • % Done changed from 50 to 80

I have found the following solution to use "wildcards" in the windows build:

for /f %%i in ('python -c "import os; print os.path.split([os.path.join(r,f) for r,d,fs in os.walk('.') for f in fs if f.endswith('RSCConfig.cmake')][0])[0]"') do set RSC=%%i

project\build_vs9.bat -DCMAKE_BUILD_TYPE=debug "-DRSC_DIR=%RSC%" 

#13 Updated by J. Moringen over 7 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

I think we updated the relevant pieces of documentation and created/updated the relevant build jobs.

If this problem persists, please reopen the issue. For distinct problems, please file reports in new issues.

Also available in: Atom PDF