Bug #1816

rsb-python 0.10 not deployed to pypi

Added by Anonymous over 7 years ago. Updated over 7 years ago.

Status:ResolvedStart date:03/19/2014
Priority:HighDue date:
Assignee:J. Wienke% Done:

100%

Category:Python
Target version:rsb-0.10

Description

When trying the python basic communication example from the rsb trunk documentation, I get an AttributeError: __exit__ in the with statement (with rsb.createInformer("/example/informer", dataType=str) as informer:):

Traceback (most recent call last):
  File "basic.py", line 10, in <module>
    with rsb.createInformer("/example/informer", dataType=str) as informer:
AttributeError: __exit__

I am using the rsb_python-0.11.0-py2.7.egg as it comes with easy_install rsb-python on Ubuntu Precise 64bit.

History

#1 Updated by J. Wienke over 7 years ago

I can't reproduce this. Any special transport?

#2 Updated by J. Wienke over 7 years ago

Oh I see the problem. There seems to be no upload of rsb version 0.10 to pip. What is the output of

import rsb.version
rsb.version.getVersion()

#3 Updated by J. Wienke over 7 years ago

  • Subject changed from Python: "with ... as informer" raises AttributeError: __exit__ to rsb-python 0.10 not deployed to pypi
  • Status changed from New to Resolved

I have added a CI job to deploy version 0.10 to pypi. Once you update your local installation everything should work

#4 Updated by J. Wienke over 7 years ago

  • Target version changed from rsb-0.11 to rsb-0.10
  • % Done changed from 0 to 100

Also available in: Atom PDF