Bug #2020

boost::signal is deprecated

Added by R. Haschke over 6 years ago. Updated over 6 years ago.

Status:RejectedStart date:09/24/2014
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

In file included from /vol/rsb/include/rsb0.11/rsb/Participant.h:35:0,
from /vol/rsb/include/rsb0.11/rsb/Informer.h:42,
from ../../src/RSBSender.hpp:3,
from ../../src/RSBSender.cpp:1:
/usr/include/boost/signal.hpp:17:4: warning:
#warning "Boost.Signals is no longer being maintained and is now deprecated. Please switch to Boost.Signals2. To disable this warning message, define BOOST_SIGNALS_NO_DEPRECATION_WARNING."


Related issues

Duplicates Robotics Service Bus - Tasks #1979: Port to Boost.Signals2 Resolved 09/03/2014

History

#1 Updated by J. Wienke over 6 years ago

  • Status changed from New to Rejected

duplicate of #1979

#2 Updated by J. Wienke over 6 years ago

Also available in: Atom PDF