Bug #2039

rsb-loggercpp0.11 doesn't format payload anymore

Added by R. Haschke almost 7 years ago. Updated almost 7 years ago.

Status:ClosedStart date:10/06/2014
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:C++ Tools
Target version:-

Description

The PayloadFormatter doesn't find the different configured PayloadFormatters anymore,
because "unknown" types get converted to "bytearray". RST types - if convertes are registered -
are converted to an rst.* type. Hence, the type will never match "pb-message" nor the
other registered formatters.

        PayloadFormatterFactory::PayloadFormatterFactory() {
            this->register_("std::string",
        &StringPayloadFormatter::create);
            this->register_("bytes",
        &BytesPayloadFormatter::create);
            this->register_("pb-message",
        &ProtocolBufferPayloadFormatter::create);

        this->register_(rsc::runtime::typeName<rsb::EventsByScopeMap>(),  &EventsByScopeMapFormatter::create);
        }

History

#1 Updated by J. Wienke almost 7 years ago

  • Description updated (diff)

#2 Updated by J. Wienke almost 7 years ago

Are you speaking of implication from a user configuration, e.g. loaded RST-converter plugins?

#3 Updated by R. Haschke almost 7 years ago

The problem is not related to loaded converted plugins, but occurs with an empty config as well

#4 Updated by J. Wienke almost 7 years ago

I don't get what you mean. At least formatting strings works perfectly here:

jwienke@cinnabar:~$ rsb-loggercpp0.11 --style detailed /foo
Event
  Scope           /foo/
  Id              EventId[participantId = UUID[09beb48c-ac98-4382-86e7-3bb6bd97b6c1], sequenceNumber = 0]
  Type            std::string
  Origin          09beb48c-ac98-4382-86e7-3bb6bd97b6c1
Timestamps
  Create  2014-Oct-06 15:13:35.274452+??:??
  Send    2014-Oct-06 15:13:35.324892+??:??
  Receive 2014-Oct-06 15:13:35.379522+??:??
  Deliver 2014-Oct-06 15:13:35.379524+??:??
Payload (std::string, length 11)
  test string
-------------------------------------------------------------------------------

#5 Updated by R. Haschke almost 7 years ago

  • Status changed from New to Rejected

OK. Talked to Jan. ProtocolBufferPayloadFormatter never actually worked. And with sending strings I had issues as well ;-)

#6 Updated by J. Moringen almost 7 years ago

  • Category set to C++ Tools

#7 Updated by R. Haschke almost 7 years ago

  • Status changed from Rejected to Closed

Also available in: Atom PDF