Bug #2083

rsb-java maven/jenkins build on ubuntu14.04 fails executing ant tasks

Added by V. Richter almost 7 years ago. Updated over 6 years ago.

Status:RejectedStart date:11/10/2014
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Build System
Target version:rsb-0.12

Description

I am currently trying to build the lsp-csra-nightly distribution on my laptop with ubuntu 14.04 and the rsb-java-master build fails.

  • The corrsponding console output in jenkins is:
[master] $ /bin/sh -xe /tmp/hudson124247022976005439.sh
+ ./mvnprep.sh
We are not on a release branch, not changing the version. You can build now!
[master] $ mvn -Dtag=2014-11-10_14-38-48 -Dlabel=master -Dpbuf.protopath=/vol/csra/releases/nightly/share/rsbprotocol0.11 -DaltDeploymentRepository=toolkit::default::file:///vol/csra/releases/nightly/share/repository -Dpbuf.protoc=/usr/bin/protoc -DoutputDirectory=/vol/csra/jenkins/jobs/rsb-java-master-toolkit-nightly/workspace/label/master/.dependencies -DassembleDirectory=/vol/csra/releases/nightly/opt/rsb-java -Dmdep.copyPom=true -Dmaven.repo.local=/home/vrichter/.m2/repo-toolkit-nightly -DskipTests=true -Dspread.daemon=/vol/csra/releases/nightly/sbin/spread install deploy dependency:copy-dependencies
[INFO] Scanning for projects...
[INFO] Searching repository for plugin with prefix: 'dependency'.
[INFO] ------------------------------------------------------------------------
[INFO] Building RSB
[INFO]    task-segment: [install, deploy, dependency:copy-dependencies]
[INFO] ------------------------------------------------------------------------
[INFO] [enforcer:enforce {execution: enforce-external-dependencies}]
[INFO] artifact com.google.protobuf:protobuf-java: checking for updates from central
[INFO] [jacoco:prepare-agent {execution: pre-unit-test}]
[INFO] argLine set to -javaagent:/home/vrichter/.m2/repo-toolkit-nightly/org/jacoco/org.jacoco.agent/0.6.3.201306030806/org.jacoco.agent-0.6.3.201306030806-runtime.jar=destfile=/vol/csra/jenkins/jobs/rsb-java-master-toolkit-nightly/workspace/label/master/target/jacoco.exec,excludes=spread/**/*.*:tutorial/**/*.*:rsb/protocol/**/*Type*.*
[WARNING] DEPRECATED [tasks]: Use target instead
[INFO] [antrun:run {execution: generate-protocol}]
[WARNING] Parameter tasks is deprecated, use target instead
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error executing ant tasks: org.apache.tools.ant.launch.Locator.fromJarURI(Ljava/lang/String;)Ljava/lang/String;

[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2 seconds
[INFO] Finished at: Mon Nov 10 14:51:02 CET 2014
[INFO] Final Memory: 30M/342M
[INFO] ------------------------------------------------------------------------
Build step 'Invoke top-level Maven targets' marked build as failure
Skipping publisher since build result is FAILURE
Finished: FAILURE
  • Checking rsb-java out and calling maven deploy directly leads to the same error:
 
./mvnprep.sh
mvn deploy -Dpbuf.protopath=/vol/csra/releases/nightly/share/rsbprotocol0.11/ -Dspread.daemon=/vol/csra/releases/nightly/sbin/ -e
+ Error stacktraces are turned on.
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building RSB
[INFO]    task-segment: [deploy]
[INFO] ------------------------------------------------------------------------
[INFO] [enforcer:enforce {execution: enforce-external-dependencies}]
[INFO] [jacoco:prepare-agent {execution: pre-unit-test}]
[INFO] argLine set to -javaagent:/home/vrichter/.m2/repository/org/jacoco/org.jacoco.agent/0.6.3.201306030806/org.jacoco.agent-0.6.3.201306030806-runtime.jar=destfile=/vol/csra/sandbox/rsb.git.java/target/jacoco.exec,excludes=spread/**/*.*:tutorial/**/*.*:rsb/protocol/**/*Type*.*
[WARNING] DEPRECATED [tasks]: Use target instead
[INFO] [antrun:run {execution: generate-protocol}]
[WARNING] Parameter tasks is deprecated, use target instead
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error executing ant tasks: org.apache.tools.ant.launch.Locator.fromJarURI(Ljava/lang/String;)Ljava/lang/String;

[INFO] ------------------------------------------------------------------------
[INFO] Trace
org.apache.maven.lifecycle.LifecycleExecutionException: Error executing ant tasks: org.apache.tools.ant.launch.Locator.fromJarURI(Ljava/lang/String;)Ljava/lang/String;
    at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:719)
    at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:556)
    at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:535)
    at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
    at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
    at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
    at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
    at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
    at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
    at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
    at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
    at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
    at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
Caused by: org.apache.maven.plugin.MojoExecutionException: Error executing ant tasks: org.apache.tools.ant.launch.Locator.fromJarURI(Ljava/lang/String;)Ljava/lang/String;
    at org.apache.maven.plugin.antrun.AntRunMojo.execute(AntRunMojo.java:360)
    at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
    at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
    ... 17 more
Caused by: java.lang.NoSuchMethodError: org.apache.tools.ant.launch.Locator.fromJarURI(Ljava/lang/String;)Ljava/lang/String;
    at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:284)
    at org.apache.tools.ant.helper.ProjectHelper2.parseUnknownElement(ProjectHelper2.java:131)
    at org.apache.tools.ant.helper.ProjectHelper2.parseAntlibDescriptor(ProjectHelper2.java:111)
    at org.apache.tools.ant.taskdefs.Antlib.createAntlib(Antlib.java:91)
    at org.apache.tools.ant.taskdefs.Definer.loadAntlib(Definer.java:440)
    at org.apache.tools.ant.taskdefs.Definer.execute(Definer.java:292)
    at org.apache.maven.plugin.antrun.AntRunMojo.initMavenTasks(AntRunMojo.java:558)
    at org.apache.maven.plugin.antrun.AntRunMojo.execute(AntRunMojo.java:316)
    ... 19 more
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2 seconds
[INFO] Finished at: Mon Nov 10 15:29:45 CET 2014
[INFO] Final Memory: 29M/344M
[INFO] ------------------------------------------------------------------------
  • Most of the other rsb projects buildc correctly
  • Ant is installed
    > ant -version
    Apache Ant(TM) version 1.9.3 compiled on April 8 2014
    
  • protoc is installed
    > protoc --version
    libprotoc 2.5.0
    

build.png (85.8 KB) V. Richter, 11/10/2014 03:37 PM

History

#1 Updated by J. Moringen almost 7 years ago

  • Target version set to rsb-0.11

#2 Updated by J. Wienke almost 7 years ago

This is actually something inside maven, and not directly related to rsb java. https://jira.codehaus.org/browse/MANTRUN-165

#3 Updated by J. Moringen almost 7 years ago

  • Target version changed from rsb-0.11 to rsb-0.12

#4 Updated by J. Wienke over 6 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF