Bug #2250

AssertionError

Added by M. Pohling over 6 years ago. Updated over 6 years ago.

Status:ResolvedStart date:05/06/2015
Priority:NormalDue date:
Assignee:J. Wienke% Done:

100%

Category:Java
Target version:rsb-0.13

Description

The following assertion error has occurred. May you want to add some more Exception handling to stabilize rsb.
The error was not reproduceable.

java.lang.AssertionError
    at rsb.eventprocessing.SingleThreadEventReceivingStrategy.handle(SingleThreadEventReceivingStrategy.java:119)
    at rsb.transport.socket.SocketInPushConnector.handle(SocketInPushConnector.java:152)
    at rsb.transport.socket.BusBase.handleLocally(BusBase.java:349)
    at rsb.transport.socket.BusBase.handleOutgoing(BusBase.java:408)
    at rsb.transport.socket.RefCountingBus.handleOutgoing(RefCountingBus.java:116)
    at rsb.transport.socket.SocketOutConnector.push(SocketOutConnector.java:116)
    at rsb.eventprocessing.DefaultOutRouteConfigurator.publishSync(DefaultOutRouteConfigurator.java:89)
    at rsb.Informer$InformerStateActive.send(Informer.java:157)
    at rsb.Informer.send(Informer.java:295)
    at de.citec.jul.rsb.com.RSBInformerPool.send(RSBInformerPool.java:181)
    at de.citec.jul.rsb.com.RSBDistributedInformer.send(RSBDistributedInformer.java:117)
    at de.citec.jul.rsb.com.RSBCommunicationService.notifyChange(RSBCommunicationService.java:191)
    at de.citec.jul.rsb.com.RSBCommunicationService.requestStatus(RSBCommunicationService.java:235)
    at de.citec.jul.rsb.com.RSBCommunicationService$1.internalInvoke(RSBCommunicationService.java:125)
    at rsb.patterns.LocalMethod.internalNotify(LocalMethod.java:99)
    at rsb.eventprocessing.SingleThreadEventReceivingStrategy$DispatchThread.run(SingleThreadEventReceivingStrategy.java:98)

    at rsb.patterns.RemoteMethod.internalNotify(RemoteMethod.java:210)
    at rsb.eventprocessing.SingleThreadEventReceivingStrategy$DispatchThread.run(SingleThreadEventReceivingStrategy.java:98)

Associated revisions

Revision d1195c8a
Added by J. Wienke over 6 years ago

Handle interruption consistently

Do not swallow interruption states as described here:
http://www.ibm.com/developerworks/library/j-jtp05236/

This slightly changes the API of Future, LocalServer and RemoteServer because
blocking methods should throw InterruptedExceptions to indicate that
interruption has occurred instead of swallowing this information.

refs #2250

Revision 22696524
Added by J. Wienke over 6 years ago

Handle interruption consistently

Do not swallow interruption states as described here:
http://www.ibm.com/developerworks/library/j-jtp05236/

This version for 0.12 preserves the API for the stable release.

fixes #2250

(cherry picked from commit 57bd547b515eef15ae6c04c2f24f4b710afb222e)

History

#1 Updated by J. Wienke over 6 years ago

  • Description updated (diff)

#2 Updated by J. Wienke over 6 years ago

  • Status changed from New to In Progress
  • Assignee set to J. Wienke
  • Target version changed from rsb-0.12 to rsb-0.13

#3 Updated by J. Wienke over 6 years ago

I suspect this happened while deactivating a Participant. Can you confirm this?

#4 Updated by J. Wienke over 6 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF