Bug #1124

Debian package rsb-tools-cpp0.7 depends strictly on rsb0.7 ...

Added by C. Emmerich about 9 years ago. Updated over 8 years ago.

Status:ClosedStart date:08/03/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

... but should depend on either rsb0.7 or rsb0.7-with-spread.


Related issues

Related to Robotics Service Bus - Enhancement #1123: Improve documentation for debian package installation wrt... New 08/03/2012

History

#1 Updated by J. Wienke about 9 years ago

I suspect we need kind of a meta package here? Or do debian packages have a "provides" option?

#2 Updated by J. Wienke about 9 years ago

              CPACK_DEBIAN_PACKAGE_PROVIDES

                   Mandatory : NO
                   Default   : -
                   see http://www.debian.org/doc/debian-policy/ch-relationships.html#s-binarydeps
                   A virtual package is one which appears in the Provides control field of another package.

CPack seems to be able to handle this. So rsb-spread and rsb should somehow both provide an rsb metapackage where all others depend on.

#3 Updated by Anonymous about 9 years ago

Or rsb-tools-cpp0.7 specifies to depend on rsb0.7 or rsb0.7-with-spread. Wouldn't that also be possible?

#4 Updated by J. Wienke about 9 years ago

Is there something like an OR?

#5 Updated by J. Moringen over 8 years ago

  • Status changed from New to Closed

I'm closing this since I cannot find an rsb0.7-with-spread package anymore. Reopen if necessary.

Also available in: Atom PDF