Bug #934

asCompactAxisAngles() results in 'NaN' ...

Added by C. Emmerich over 10 years ago. Updated over 10 years ago.

Status:ResolvedStart date:03/08/2012
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-Estimated time:0.50 hour
Target version:-

Description

... when constructed from Orientation::fromEulerAngles(0.0, 0.0, 0.0).

Probably this is caused by a division by zero (normalization through length of vector)...

Associated revisions

Revision 560
Added by anordman over 10 years ago

Fixed zero rotation
fixes #934

History

#1 Updated by Anonymous over 10 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset r560.

Also available in: Atom PDF