Tasks #1539

Build pypi packages for rsb-python 0.9

Added by Anonymous almost 11 years ago. Updated almost 11 years ago.

Status:ResolvedStart date:06/11/2013
Priority:NormalDue date:
Assignee:J. Wienke% Done:

100%

Category:-
Target version:Robotics Service Bus - rsb-0.9

Description

Enable building of pypi packages for rsb-python 0.9 and automatic upload to pypi.org.

Find a pre-configured, yet disabled job here:
https://ci.cor-lab.org/job/rsb-python-trunk-pypi/


Related issues

Related to Robotics Service Bus - Bug #1540: Documentation for installation of rsb-python from package... Resolved 06/11/2013
Blocks Robotics Service Bus - Tasks #1562: Release version 0.9 Resolved 08/07/2013 08/07/2013

History

#1 Updated by J. Wienke almost 11 years ago

This has to be done after the release. We do not want to spam pypi with non-release version packages. Moreover, users who want to have a released version would otherwise automatically receive the pre-release versions.

#2 Updated by J. Wienke almost 11 years ago

Hm, maybe we could even upload pre-release versions: http://www.pip-installer.org/en/latest/logic.html#pre-release-versions

#3 Updated by J. Wienke almost 11 years ago

  • Status changed from New to In Progress

#4 Updated by J. Wienke almost 11 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Done after hacking around a current pylint problem.

Also available in: Atom PDF