Bug #2625

rst-converters-cpp does not build with modern Eigen 3 versions (e.g. Ubuntu Xenial)

Added by J. Moringen about 5 years ago. Updated about 4 years ago.

Status:ResolvedStart date:07/26/2016
Priority:NormalDue date:
Assignee:J. Moringen% Done:

100%

Category:cpp
Target version:Robotics Service Bus - rsb-0.18

Description

rst-converters-cpp depends on Eigen 3's Eigen 2 compatibility layer (via rst-converters-cpp -> rci -> nemomath -> Eigen 3) which has is no longer provided by modern Eigen 3 versions.


Related issues

Related to Robotics Systems Types - Tasks #2626: Separate libraries for protocol buffer converter plugins ... In Progress 07/26/2016

History

#1 Updated by J. Moringen about 5 years ago

  • Related to Tasks #2626: Separate libraries for protocol buffer converter plugins and specialized converter plugins added

#2 Updated by J. Moringen almost 5 years ago

  • Target version changed from rsb-0.15 to rsb-0.16

#3 Updated by J. Moringen over 4 years ago

  • Target version changed from rsb-0.16 to rsb-0.17

#4 Updated by J. Moringen over 4 years ago

  • Status changed from New to Resolved
  • Assignee set to J. Moringen
  • % Done changed from 0 to 100

Removed RCI converters.

#5 Updated by J. Moringen about 4 years ago

  • Target version changed from rsb-0.17 to rsb-0.18

Also available in: Atom PDF